Back to overview
Degraded

Degraded performance on Platform

Aug 22, 2023 at 03:45pm UTC

Resolved
Aug 22, 2023 at 04:20pm UTC

This incident has been resolved.

Updated
Aug 22, 2023 at 04:03pm UTC

Our engineers have pinpointed the root cause of the issue and are monitoring the situation to ensure a complete resolution.

Updated
Aug 22, 2023 at 03:53pm UTC

We are currently investigating an issue that may cause some customers to experience slower "Party" reading operations.

Created
Aug 22, 2023 at 03:45pm UTC

Our engineers are observing degraded performance on some platform functionality.