Back to overview
Degraded

Signing documents issues

Sep 14 at 04:14am EDT
Affected services
Platform

Resolved
Sep 14 at 07:43am EDT

The issue has been resolved.

Updated
Sep 14 at 07:18am EDT

Our engineers are currently monitoring the situation to ensure that it is fully resolved.

Updated
Sep 14 at 05:20am EDT

Our engineers have pinpointed the root cause of the issue and are implementing a fix to deploy ASAP.

Created
Sep 14 at 04:14am EDT

Our engineers have identified some issues with document signing operations.