Back to overview
Downtime

Google Cloud Major Outage

Jun 12 at 02:34pm EDT
Affected services
Dashboard
Public API
Internal API
Gateway
Review & Payment page
Licenses
External Providers Integrations
External Providers Coordinator
File Manager
Insights
Scheduler
Coordinator
Pipeline

Resolved
Jun 13 at 03:15am EDT

In the coming days, Google will publish a full incident report of the root cause, a detailed timeline, and robust remediation steps Google will be taking. Please note, this information is based on Google’s best knowledge at the time of posting and is subject to change as Google’s investigation continues.

Customers had intermittent API and user-interface access issues to the impacted services.

Incident Start: 12 June, 2025 10:49
All regions except us-central1 mitigated: 12 June, 2025 12:48
Incident End: 12 June, 2025 13:49
Duration: 3 hours
Regions/Zones: Global

Multiple Google Cloud and Google Workspace products experienced increased 503 errors in external API requests, impacting customers.
From Google’s initial analysis, the issue occurred due to an invalid automated quota update to Google’s API management system, which was distributed globally, causing external API requests to be rejected. To recover, Google bypassed the offending quota check, which allowed recovery in most regions within 2 hours. However, the quota policy database in us-central1 became overloaded, resulting in much longer recovery in that region. Several products hada moderate residual impact (e.g. backlogs) for up to an hour after the primary issue was mitigated, and a small number recovered after that.

Google will complete a full Incident Report in the following days that will provide a detailed root cause.

https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW

Updated
Jun 12 at 05:00pm EDT

Google has implemented mitigation for the issue in us-central1 and multi-region/us, and signs of recovery are being observed.

Full recovery is expected to be completed within the next hour.

https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW

Updated
Jun 12 at 03:45pm EDT

Google's engineers have identified the root cause and implemented appropriate mitigations.

Although Google's engineers have confirmed that the underlying dependency has recovered in all locations except us-central1 (the main zone of TrustLayer), some services may still be experiencing disruptions.

Updated
Jun 12 at 03:01pm EDT

Google has released its first update regarding the major outage: several GCP products are affected due to an issue with the Identity and Access Management Service.

https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW

Created
Jun 12 at 02:34pm EDT

We’re currently impacted by a major Google Cloud outage affecting many services, including TrustLayer.

This issue stems from Google’s infrastructure. As soon as their systems are back online, we’ll restore full service — but at this time, there’s no estimated resolution.
We’ll keep monitoring and share updates when we know more. Appreciate your patience.

Status updates from Google are available here: https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW#RP1d9aZLNFZEJmTBk8e1