Back to overview
Degraded

Service disruption affecting AWS us-east datacenter

Oct 20 at 05:01am EDT
Affected services
Dashboard
Public API
Internal API
Gateway
Insights

Resolved
Oct 20 at 06:07am EDT

AWS has confirmed that the issue impacting the us-east-1 region is now fully resolved.

Updated
Oct 20 at 05:35am EDT

We have received an update from AWS indicating significant signs of recovery following the disruption in the us-east region related to DNS resolution issues.

We will continue to monitor the situation until AWS reports full resolution to ensure all indirect impacts are completely cleared.

Updated
Oct 20 at 05:20am EDT

The underlying issue at AWS is still ongoing and is affecting the us-east-1 region. The AWS team has identified a potential root cause related to DNS resolution problems that are impacting multiple services across the region.

This disruption continues to affect several AWS services and global features that rely on the us-east-1 region.

Created
Oct 20 at 05:01am EDT

AWS is currently experiencing a service outage at its US East (N. Virginia) datacenter, which is affecting some of our systems.

While our core infrastructure and applications are not directly affected by this AWS outage, many third-party services, dependencies, and external functionalities that we rely on do use AWS.

Impact:
- Customers may experience intermittent errors or increased latency when using features that rely on these external, AWS-dependent services.
- Functionalities potentially affected include (but are not limited to) specific third-party integrations, external data fetching, and similar components.

Our teams are continuing to monitor the situation closely and are working with our vendors to mitigate any indirect impact. We will post another update once AWS reports a major change in status or if we confirm any significant change in service performance on our end.