Back to overview
Degraded
Webflow Marketing Site Interruption
Oct 20 at 11:11am EDT
Affected services
Company Website
Resolved
Oct 20 at 04:24pm EDT
Marketing website has fully recovered and is operational.
Affected services
Created
Oct 20 at 11:11am EDT
We're experiencing intermittent issues with our marketing site due to a Webflow platform disruption with their upstream provider.
The issue is not affecting all users. Some visitors may see 500 or 504 errors or have trouble loading certain pages.
Webflow is actively investigating and has reported signs of recovery. We will share another update once the issue is fully resolved.
Affected services