Back to overview
Degraded
Email Service Delay
Jun 26 at 11:00am EDT
Affected services
Dashboard
Resolved
Jun 27 at 02:00am EDT
Email services are now operating normally.
Affected services
Dashboard
Created
Jun 26 at 11:00am EDT
We are currently experiencing issues with our email service provider, resulting in intermittent functionality of certain email-sending features for some users.
Consequently, there may be 1-2 hours delays in sending and delivering emails. We are currently working closely with our service provider to resolve the issue.
We appreciate your patience and understanding.
Affected services
Dashboard