Back to overview
Degraded

Platform slowness and automation delays

Sep 18 at 12:30pm EDT

Resolved
Sep 18 at 02:20pm EDT

We’ve identified and resolved the root cause. The fix is now in place and will be fully deployed for all users within the coming hours.

Created
Sep 18 at 12:30pm EDT

We’ve identified an issue causing platform slowness and automation delays related to compliance. You may notice delays, particularly with bulk operations, such as sending reports.